php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18489 Can't compile with apxs
Submitted: 2002-07-23 08:07 UTC Modified: 2002-07-23 10:41 UTC
From: benoit dot bruckert at uniporc-ouest dot com Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.2.1 OS: HPUX11.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: benoit dot bruckert at uniporc-ouest dot com
New email:
PHP Version: OS:

 

 [2002-07-23 08:07 UTC] benoit dot bruckert at uniporc-ouest dot com
To compile php on HP-UX 11.00. system (PA-RISK) SMP with gcc compiler, I followed these steps :
1. configure Apache with so, make, make install, test : It's OK
2. in php source directory : ./configure --with-apxs=/opt/apache/bin/apxs
At the make time I have an error 1 
Compilation in static mode works without pb...
Now I would like to upgrade to Apache2.0.39, static is not available, then I had to find a way to solve it...
From mailing list, and man pages here's the way I used :
1. change sapi/apache2filter/php_functions.c, replace "MODULE_MAGIC_AT_LEAST" to "AP_MODULE_MAGIC_AT_LEAST"
If I make, then I have another error with c_time_r and asctime_r from main/reentrancy.c.
To solve it, edit reentrancy.c :
Add "&& !defined(PHP_HPUX_TIME_R)" 
 at the end of these 4 lines : 
#if !defined(HAVE_LOCAL_TIME_R) && (defined(HAVE_LOCALTIME) 
#if !defined(HAVE_CTIME_R) && (defined(HAVE_CTIME) 
#if !defined(HAVE_ASCTIME_R) && (defined(HAVE_ASCTIME) 
#if !defined(HAVE_GMTIME_R) && (defined(HAVE_GMTIME) 

change the functions c_time_r : 
if (ctime_r(clock, buf, 26) != -1) 
to 
if (ctime_r(clock, buf) != -1) 
(2 times in this source file) 
Do the same with asctime_r : 
if (asctime_r(tm, buf, 26) != -1) 
to 
if (asctime_r(tm, buf) != -1) 
(2 times also). 

then make is OK, make install also.

last remark with OCI8 on HP-UX11.00 (not linked with the bug report), define LD_PRELOAD="/usr/lib/libcl.2" ; export LD_PRELOAD before running Apache (in case of version 2.0.39 multi thread).

Hope it will help

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-23 10:41 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 25 05:03:35 2022 UTC