php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18479 Bad Error Message: (libgd)
Submitted: 2002-07-22 18:22 UTC Modified: 2003-05-29 12:14 UTC
From: ewhite at stsci dot edu Assigned:
Status: Closed Package: GD related
PHP Version: 4.2.1 OS: Doesn't Matter
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ewhite at stsci dot edu
New email:
PHP Version: OS:

 

 [2002-07-22 18:22 UTC] ewhite at stsci dot edu
When you include gd support through configure, at some point it takes steps to actually detect, and make sure that libgd exists on your machine.

It does separate checks, looking for a lib/libgd.(a|so), as well as a check for include/gd.h

The problem is (which I ran into), that the error message for either of these checks failing is:

configure: error: Unable to find libgd.(a|so) anywhere under 'blah'

In my case, it WAS finding libgd.a, but it was complaining because it couldn't find gd.h   It took me lots of hair pulling to finally figure out (via scanning the configure scripts) that it was actually complaining about not seeing gd.h where it expected it.

The error message should EITHER specify which error occured (preferrable), or give a more generic error message of: "can't find libgd.a OR gd.h"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-22 21:11 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 [2003-05-29 12:00 UTC] sellingsolutions at hotmail dot com
I am having this same problem in the current PHP ver 4.3.1.

Is this a new bug or does the source need to be updated?

Thank you,

Eric
 [2003-05-29 12:14 UTC] wez@php.net
4.3.2 was released today - try it out.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 02:01:23 2021 UTC