php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18445 when file upload, the size is duplicated
Submitted: 2002-07-19 23:30 UTC Modified: 2002-07-22 20:34 UTC
From: youngga at hotmail dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 4.2.1 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: youngga at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-07-19 23:30 UTC] youngga at hotmail dot com
When I file upload with http form, the uploaded file size is duplicated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-20 04:19 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-07-21 01:31 UTC] youngga at hotmail dot com
When I upload file to server, stored file size in server is duplicated.
My test page is www.ftpmail.com/test/a_file.php.
And you can see my php information at www.ftpmail.com/test.php .

The full source is following.
-----------------------------------------------------------
<html>

<head>
<title>test_array</title>
</head>

<body>
<table align="center" border="0">
<tr>
<td>
<p>Array file upload test page.

<p>Select file then click submit.</p>

<form name="files_up" action="<? echo $PHP_SELF; ?>" method="post" enctype='multipart/form-data'>
	<input class="input" type="file" name="upfile" size="25"><br> 
	<input type="submit" name="sub1" value="submit"> 

</form>
	<?php
	if(!empty($upfile))
	{
			echo "<br>file name = ".$upfile_name;
			echo "<br>file size = ".$upfile_size."<br>";
	}
	?>
<p>&nbsp;</p>
<p><a href="menu.htm">go to menu</a></p>
		</td>
</tr></table>
</body>
</html>
-----------------------------------------------------------

please answer the solutions.
 [2002-07-21 01:40 UTC] youngga at hotmail dot com
When I upload file to server, stored file size in server is duplicated.
My test page is www.ftpmail.com/test/a_file.php.
And you can see my php information at www.ftpmail.com/test.php .

The full source is following.
-----------------------------------------------------------
<pre>
<html>

<head>
<title>test_array</title>
</head>

<body>
<table align="center" border="0">
<tr>
<td>
<p>Array file upload test page.

<p>Select file then click submit.</p>

<form name="files_up" action="<? echo $PHP_SELF; ?>" method="post"
enctype='multipart/form-data'>
	<input class="input" type="file" name="upfile" size="25"><br> 
	<input type="submit" name="sub1" value="submit"> 

</form>
	<?php
	if(!empty($upfile))
	{
			echo "<br>file name = ".$upfile_name;
			echo "<br>file size = ".$upfile_size."<br>";
	}
	?>
<p>&nbsp;</p>
<p><a href="menu.htm">go to menu</a></p>
		</td>
</tr></table>
</body>
</html>
</pre>
-----------------------------------------------------------

please answer the solutions.
 [2002-07-22 20:34 UTC] youngga at hotmail dot com
I changed aparch version from 2.0.39 to 1.3.26 and the problem was disappeared.
But I doubt PHP is well operating.
Above test url is not avaible from now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 08:01:23 2020 UTC