php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18439 Confusion over possible syntax error.
Submitted: 2002-07-19 14:16 UTC Modified: 2002-07-19 14:34 UTC
From: vmcore at mysun dot com Assigned:
Status: Not a bug Package: *Programming Data Structures
PHP Version: 4.2.1 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vmcore at mysun dot com
New email:
PHP Version: OS:

 

 [2002-07-19 14:16 UTC] vmcore at mysun dot com
Unsure if this is a syntax error or a confusion on my part.
Code:
<?
$string = "String of text." .
     " Plus a little more text.";
     " This won't show up but it should be a syntax error.";
echo $string;
?>
This was screwing up one of my query's and I was having an issue locating the problem.
= Josh =

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-19 14:28 UTC] jan@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

set your error reporting to E_ALL
error_reporting(E_ALL);
 [2002-07-19 14:34 UTC] vmcore at mysun dot com
Apparently this can be done in any language and is just treated as a comment, though i don't quite understand why it's not a syntax error since we already have enough ways to comment.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jan 19 09:01:23 2021 UTC