php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18431 Mail fonction () Not Sending!
Submitted: 2002-07-19 05:04 UTC Modified: 2002-07-23 15:33 UTC
From: jordan23 at pt dot lu Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4CVS-2002-07-19 OS: Windows 2K Ad. Server SP2 - IIS5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jordan23 at pt dot lu
New email:
PHP Version: OS:

 

 [2002-07-19 05:04 UTC] jordan23 at pt dot lu
example:

--------------------------------------------------------

<?php 

/* 
Send a simple message with plain text and no attachments. 
*/ 

if ($showsource) { 
show_source ($SCRIPT_FILENAME); 
exit; 
} 

include_once("../../vlibMimeMail.php"); 

$mail= new vlibMimeMail; // create the mail 
$mail->to('akumschick@kumschicknw.com', 'Alain Kumschick'); 
$mail->from('root@kumschicknw.com', 'Root'); 
$mail->subject("this is a test subject"); 
$mail->body("Hello\n\nThis is a plain text body for the mail!"); // set the body 

/* send the mail (this is commented out as it's purely documentational) */
 
$mail->send(); 
echo "<pre>", $mail->get(), "</pre>"; // and echo the entire body of the mail to see what it looks like 
?>

<a href="example1.php?showsource=1">show source</a>

--------------------------------------------------------


here is an example i got from a site to send emails with the mail fonction(), under linux/unix the script works fine, but under Windows 2000 Advanced Server Service Pack 2 with IIS5 i get NO error message anymore (befor php v4.0.6 and now v4.2.2-dev) but the email is not sending! 

and the "$SCRIPT_FILENAME" doesn't work to! is there a reasen?

error msg: Warning: Failed opening '' for highlighting ...



example is there: (windows machine)
http://www.kumschicknw.com/apps/postcard/test/examples/vlibMimeMail/example1.php


email:
Alain Kumschick <akumschick@kumschicknw.com> or <jordan23@pt.lu>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-19 05:12 UTC] sniper@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 [2002-07-19 05:19 UTC] jordan23 at pt dot lu
if i trun it off, the script still doesn't work!
the server doesn't send the email!
 [2002-07-19 05:25 UTC] sniper@php.net
Try turning it on? And you should show us the script SOURCE
at the url you gave..

 [2002-07-19 05:29 UTC] jordan23 at pt dot lu
nop!if i turn it on i get an error message. under a linux machine, no problem, but under windows, hummm... not good!

error msg:
Warning: Failed opening '' for highlighting in D:\web\web\allpages\kumschick\kumschicknw_new\apps\postcard\test\examples\vlibMimeMail\example1.php on line 7

and the "register_globals" must be ON, on that computer. if i remember right, it's also on under linux.
 [2002-07-23 15:33 UTC] hholzgra@php.net
so what is this one actualy about?

mail(), vlibMimeMail or show_source()?

please check your mail configuration first
with a short script using only the mail() function itself

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 11:03:42 2023 UTC