|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18423 IMAP - referenced symbol ssl_onceonlyinit not found
Submitted: 2002-07-18 16:37 UTC Modified: 2002-09-11 11:43 UTC
From: gpreston at ycp dot edu Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 4.2.1 OS: Solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
23 + 27 = ?
Subscribe to this entry?

 [2002-07-18 16:37 UTC] gpreston at ycp dot edu
I'm trying to implement PHP with IMAP SSL and am running into a few problems.  I have:
-OpenSSL 0.9.6d
-Apache 2.0.39
and this is all running on a Solaris 9 (Sparc) machine.  Everything compiles and installs just fine, but when I attempt to start up the HTTPD, it crashes with the following output:

# /web/bin/apachectl startssl
Syntax error on line 230 of /web/conf/httpd.conf:
Cannot load /web/modules/ into server: /web/bin/httpd: fatal: relocation error: file /web/modules/ symbol ssl_onceonlyinit: referenced symbol not found

My configure for PHP is as follows:
CC=gcc ./configure  --with-apxs2=/web/bin/apxs --with-mysql --with-imap=/tmp/gabe/new-owl/imap-2002 --with-imap-ssl=/tmp/gabe/new-owl/imap-2002.RC2 --with-openssl --with-gettext --with-xml --with-zlib
My first attempt I tried with just --with-imap-ssl, but that died on me in the make, so then I added the --with-imap, and that still gave me problems, so then I finally added the --with-openssl and everything worked just fine.  Now I'm not exactly sure where the problem lies.  For the time being, I'm stepping back and will just use --with-imap and nothing else, but it would be a great help if I could implement the --with-imap-ssl at a later date.

Any suggestions or do you need more info?


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-18 17:49 UTC]
Is your c-client library compiled with SSL support?

Also try this snapshot:

 [2002-07-19 10:15 UTC] gpreston at ycp dot edu
Yeah, I had compiled the c-client library with SSL with the following:

make gso SSLTYPE=unix

I'll try the latest CVS and see how this works for me.
 [2002-07-19 12:15 UTC]
Are you sure that the c-client really HAS the SSL support?

Check if it really has the symbol:

# nm libc-client.a | grep ssl_once

 [2002-09-11 11:43 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jun 19 22:01:22 2021 UTC