php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18398 Sporadic link failure/invalid link error
Submitted: 2002-07-17 17:42 UTC Modified: 2002-07-18 17:55 UTC
From: vmcore at mysun dot com Assigned:
Status: Closed Package: Sybase (dblib) related
PHP Version: 4.1.2 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vmcore at mysun dot com
New email:
PHP Version: OS:

 

 [2002-07-17 17:42 UTC] vmcore at mysun dot com
Build string:
./configure --prefix=/local/opt --enable-static=mysql --enable-static=sybase --with-mysql=/local/opt/mysql --with-sybase=/local/run/tp/sybase/OpenClientServer/v11.1.1ebf8262 --with-apxs=/local/opt/apache/bin/apxs

Version: 4.1.2

Errors:
Warning: 0 is not a Sybase link index in /sbclocal/opt/icenine/www/dev/checksheets/include/checksheet_web.class.php on line 145

Warning: -1 is not a Sybase link index in /sbclocal/opt/icenine/www/dev/checksheets/include/checksheet_web.class.php on line 1809

Warning: 0 is not a Sybase result index in /sbclocal/opt/icenine/www/dev/checksheets/include/checksheet_web.class.php on line 1811

Connect Statement:
function dbConnect () // Create basic connection
{
	// create linkid
	$this->dbLinkid	= sybase_connect("$this->dbHost", "$this->dbUser", "$this->dbPass");
		
	// select database
	sybase_select_db($this->dbDbase, $this->dbLinkid);
	
} // dbConnect

It's quite sporadic. Sometimes the errors are different. I was using the same syntax with mysql, but I never had any issues.

= Josh =

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-17 17:48 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


You should also try using --with-sybase-ct instead..

 [2002-07-17 21:17 UTC] vmcore at mysun dot com
4.2.1 doesn't work with my variable setup for some reason. My variables are not passed from page to page. Right now I declare my variables as global in my constructor and then assign them to class values such as:
global $var;
$this->var = $var;
this seems to work. Variables set outside the constructor such as
var $somevar;
don't seem to work unless i assign them static values. Maybe I'm doing something incorrectly but I cannot seem to get it to work the other way around.
= Josh =
 [2002-07-18 04:49 UTC] sniper@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.


 [2002-07-18 17:55 UTC] vmcore at mysun dot com
It appears that upgrading to 4.2.1 did indeed alleviate my problems. I'm going to have to learn how to properly setup variables because i'm sure that the way i'm doing it now is all wrong, even if it does work. In any case, if I see any reoccurance of the same type of behaviour I'll update this ticket, although I really doubt it will resurface. Thank you for the help and pointers.
= Josh =
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 29 07:01:30 2020 UTC