php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18331 ob_implicit_flush(true) no longer working
Submitted: 2002-07-13 13:16 UTC Modified: 2002-09-21 18:27 UTC
From: cox at idecnet dot com Assigned:
Status: Closed Package: Output Control
PHP Version: 4.3.0-dev OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
44 - 40 = ?
Subscribe to this entry?

 
 [2002-07-13 13:16 UTC] cox at idecnet dot com
<?php
ob_implicit_flush(true);
echo "start\n";
sleep(5);
?>

With PHP <= 4.1.x, I get "start" just after execute the script. With PHP 4.2.1 CGI I have to wait 5 seconds before get any output. The problem is not reproduceable with CLI under Linux but CLI under Windows have it.

Tomas V.V.Cox

PS.- You need to have output_buffering=4096 and inmplicit_flush=Off in you php.ini to reproduce this problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-13 22:49 UTC] sniper@php.net
Reproduced in Linux with CLI..

 [2002-07-15 21:55 UTC] yohgaki@php.net
Someone needs to implement implicit flush for neseted output buffers as I post it to php-dev, today....
 [2002-09-21 18:27 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

Seems to have been fixed. Unable to replicate the problem on Linux or Windows using latest CVS.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 05:03:34 2021 UTC