php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18330 Problems in determining PHP_SELF
Submitted: 2002-07-13 07:04 UTC Modified: 2002-07-13 07:08 UTC
From: dados at impazz dot it Assigned:
Status: Not a bug Package: URL related
PHP Version: 4.2.1 OS: Linux 2.4.2-2smp
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dados at impazz dot it
New email:
PHP Version: OS:

 

 [2002-07-13 07:04 UTC] dados at impazz dot it
Getting a page with an UURL like: http://www.domain.tld//dir/index.php will result in a misdeterming of the variable PHP_SELF which becomes: '//dir/index.php', a misspelling of the url can result in a non working webpage; linking to a malformed PHP_SELF like this one make the browser understand: 'http://dir/index.php'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-13 07:08 UTC] sander@php.net
This is not a bug. AFAIK PHP_SELF just contains the path & file info of an URL. That some browsers don't handle URL's like these correctly, is not our problem.
Not a bug in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 17 10:03:37 2021 UTC