php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18321 with-openssl : e_os.h (OpenSSL-0.9.7b) can't be included
Submitted: 2002-07-12 14:43 UTC Modified: 2002-07-12 14:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mmacwing at irisa dot fr Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.2.1 OS: ALL, test on Solaris 2.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mmacwing at irisa dot fr
New email:
PHP Version: OS:

 

 [2002-07-12 14:43 UTC] mmacwing at irisa dot fr
Hi,

With the last version of OpenSSL (0.9.7b), PHP can't include e_os.h (see "php_dir/ext/openssl/openssl.c").
In the end of this message, you can find a forward about e_os.h from Richard Levitte (Member of the OpenSSL)


./configure --prefix=/udd/mmacwing/usr/local/php-4.2.1/
--with-config-file-path=/udd/mmacwing/usr/local/php-4.2.1/
--with-apxs=/udd/mmacwing/usr/local/apache/bin/apxs
--with-openssl=/udd/mmacwing/usr/local/openssl/ --with-mysql
--enable-track-vars --enable-versioning --with-xml

Making all in openssl
/bin/sh /udd/mmacwing/usr/src/php-4.2.1/libtool --silent --mode=compile
gcc  -I. -I/udd/mmacwing/usr/src/php-4.2.1/ext/openssl
-I/udd/mmacwing/usr/src/php-4.2.1/main
-I/udd/mmacwing/usr/src/php-4.2.1
-I/udd/mmacwing/usr/local/apache_1.3.26/include
-I/udd/mmacwing/usr/src/php-4.2.1/Zend
-I/udd/mmacwing/usr/local/openssl//include
-I/udd/mmacwing/usr/src/php-4.2.1/ext/mysql/libmysql
-I/udd/mmacwing/usr/src/php-4.2.1/ext/xml/expat 
-D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI
-DSHARED_CORE -DEAPI -I/udd/mmacwing/usr/src/php-4.2.1/TSRM -O2
-I/udd/mmacwing/usr/local/openssl/include
-I/udd/mmacwing/usr/local/openldap/include -DEAPI -prefer-pic  -c
openssl.c
openssl.c:42: openssl/e_os.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `openssl.lo'
Current working directory /udd/mmacwing/usr/src/php-4.2.1/ext/openssl
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /udd/mmacwing/usr/src/php-4.2.1/ext/openssl
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /udd/mmacwing/usr/src/php-4.2.1/ext
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'

Thanks for your help.
Michel.


======================================================
Forward from Richard Levitte - Member of the OpenSSL development team :

In message <rt-145-986.2.62055893591906@openssl.org> on Fri, 12 Jul 2002
15:43:08 +0200 (METDST), "Michel Mac Wing via RT" <rt@openssl.org>
said:

e_os.h was never meant to be exported.  Starting with 0.9.7, it really
isn't exported any more.  It's a mistake for external applications to
try to use it and has always been so.

rt> when I try to compile PHP :
rt> 
rt>    Making all in openssl
rt>    /bin/sh /udd/mmacwing/usr/src/php-4.2.1/libtool --silent
rt> --mode=compile
rt>    gcc  -I. -I/udd/mmacwing/usr/src/php-4.2.1/ext/openssl
rt>    -I/udd/mmacwing/usr/src/php-4.2.1/main
rt> -I/udd/mmacwing/usr/src/php-4.2.1
rt>    -I/udd/mmacwing/usr/local/apache_1.3.26/include
rt>    -I/udd/mmacwing/usr/src/php-4.2.1/Zend
rt>    -I/udd/mmacwing/usr/local/openssl//include
rt>    -I/udd/mmacwing/usr/src/php-4.2.1/ext/mysql/libmysql
rt>    -I/udd/mmacwing/usr/src/php-4.2.1/ext/xml/expat
rt>    -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=270 -DMOD_SSL=208110
-DEAPI
rt>    -DSHARED_CORE -DEAPI -I/udd/mmacwing/usr/src/php-4.2.1/TSRM -O2
rt>    -I/udd/mmacwing/usr/local/openssl/include
rt>    -I/udd/mmacwing/usr/local/openldap/include -DEAPI -prefer-pic 
-c
rt>    openssl.c
rt>    openssl.c:42: openssl/e_os.h: No such file or directory
rt> ^^^^^^^^^^^^^^^^^^^^^^^^
rt>    *** Error code 1
rt>    make: Fatal error: Command failed for target `openssl.lo'
rt>    Current working directory
/udd/mmacwing/usr/src/php-4.2.1/ext/openssl
rt> 
rt>    *** Error code 1
rt>    make: Fatal error: Command failed for target `all-recursive'
rt>    Current working directory
/udd/mmacwing/usr/src/php-4.2.1/ext/openssl
rt> 
rt>    *** Error code 1
rt>    make: Fatal error: Command failed for target `all-recursive'
rt>    Current working directory /udd/mmacwing/usr/src/php-4.2.1/ext
rt>    *** Error code 1
rt>    make: Fatal error: Command failed for target `all-recursive'

And what exactly is attempted here?????

-- 
Richard Levitte   \ Spannv?gen 38, II \ LeViMS@stacken.kth.se
Redakteur@Stacken  \ S-168 35  BROMMA  \ T: +46-8-26 52 47
                    \      SWEDEN       \ or +46-708-26 53 44
Procurator Odiosus Ex Infernis                -- poei@bofh.se
Member of the OpenSSL development team: http://www.openssl.org/

Unsolicited commercial email is subject to an archival fee of $400.
See <http://www.stacken.kth.se/~levitte/mail/> for more info.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-12 14:53 UTC] mmacwing at irisa dot fr
This problem occurs on ALL OS (with OpenSSL-0.9.7)
 [2002-07-12 14:59 UTC] sander@php.net
We really appreciate your help but please don't open new bugs for the same problem again and again. See #18295.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 09:03:34 2021 UTC