php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18290 module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c"
Submitted: 2002-07-11 22:09 UTC Modified: 2002-07-11 22:16 UTC
From: baxant at cogeco dot ca Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: Windows 2000 & Windows XP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: baxant at cogeco dot ca
New email:
PHP Version: OS:

 

 [2002-07-11 22:09 UTC] baxant at cogeco dot ca
After installing PHP 4.2.1 on Apache 2.0.39 the only line that will not allow Apache to run is this line in the httpd.conf

LoadModule php4_module "c:/PHP/sapi/php4apache2.dll"

I have tried this with single and no quotes as well. If I Comment (#) it out Apache will run again but without PHP.

So I did the following ...  

After running Apache's test configuration in Windowscommand prompt. 

C:\Documents and Settings>"C:\Program Files\Apache Group\Apache2\bin\Apache.exe" -t -f "C:\Program Files\Apache Group\Apache2\conf\httpd.conf" -d "C:\Prog 
ram Files\Apache Group\Apache2\." 

Results: 

Apache.exe: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c"is not compatible with this version of Apache. 
Please contact the vendor for the correct version.

This is a problem. The path does not exsist at all on my computer, so why would it believe that it is there. I can see however why Apache will not restart due to the wrong path being referenced.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-11 22:16 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
 [2002-09-25 08:52 UTC] info at thundercall dot dk
well,... the problem seems to back again,..

using Apache 2.0.42 and php4.2.3,.. even snap version 4.3.0 ( date: 25-Sep-2002 03:24 )

and it looks like i am not the only one having that problem,..
 - http://www.phpgeek.com/articles.php?content_id=3


maybe i should just forget about running php as a module on Apache 2 for windows,... since it works perfectly as CGI,.. but it could fun to do some of those "module only features" :D

so where can i find the "20020903" version ?

----
APACHE.EXE: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not
compatible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.

---
Take Care and Godspeed.
 - Thundercall
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 09:03:34 2021 UTC