php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18279 configure script fails for LONG if...fi blocks
Submitted: 2002-07-11 10:48 UTC Modified: 2002-07-11 14:16 UTC
From: achowe at snert dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.1 OS: Mac OS X 10.1.5
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: achowe at snert dot com
New email:
PHP Version: OS:

 

 [2002-07-11 10:48 UTC] achowe at snert dot com
I'm trying to build PHP yet again for Mac OS X and I can't even get the configure script to complete.  The configure script fails, when using the apple.com supplied "/bin/sh",
when performing the GD tests. Commenting out the:

  if test "$PHP_GD" != "no"; then

and matching "fi" allows the script to continue. It later stops again when it comes to the LDAP tests, which again have a large number of lines.

Having already installed the pre-built "bash" from apple.com, I changed within the configure script the #! to

  #!/bin/bash 

And the script finally finished normally.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-11 14:16 UTC] sniper@php.net
You should try this snapshot:

http://snaps.php.net/php4-latest.tar.gz

It's only php version (php4.3.0-dev) which configures/compiles out-of-box on MacOSX.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 16:03:45 2022 UTC