php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18124 Some "magic values" for pdf_show_boxed give stupid output
Submitted: 2002-07-02 23:22 UTC Modified: 2002-07-02 23:47 UTC
From: ceo at l-i-e dot com Assigned:
Status: Not a bug Package: *PDF functions
PHP Version: 4.1.2 OS: OpenBSD o2 2.9 conf#0 i386
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
23 + 47 = ?
Subscribe to this entry?

 
 [2002-07-02 23:22 UTC] ceo at l-i-e dot com
PDFlib GmbH Version	3.02
Revision	$Revision: 1.94.2.1 $

--with-pdflib
Full phpinfo() output URL given inside text of URLs below.

http://uncommonground.com/bug.txt
http://uncommonground.com/bug.pdf

Note that the string is "chopped" off at 'McCarthy' but by 
any sane definition (by us humans) there is 'plenty' of room 
in the given rectangle for the text.

I can provide more examples of the same kind of broken-ness.

Look at the Bob Dylan tribute concert (July 26th) at the URL 
referenced, or the 21st (McCarthy) or the 19th (McCarthy 
again)...

It seems to be a combination of the string and the 
rectangle, as near as I can figger...   I mean, it works 
*most* of the time... :-^

If you need anything more, just holl

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-02 23:47 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

I tested with PDFlib 4.0.2 and your script works fine.
(all of the text shown) So update that..

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Aug 21 18:01:26 2019 UTC