php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18081 Apache crashes
Submitted: 2002-06-30 20:41 UTC Modified: 2002-07-01 14:48 UTC
From: drewndia at nightmail dot ru Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.0CVS-2002-06-30 OS: Win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: drewndia at nightmail dot ru
New email:
PHP Version: OS:

 

 [2002-06-30 20:41 UTC] drewndia at nightmail dot ru
Apache crashes with PHP. I supply summary of a crash gemerated by windows (there may be some wrong things due to translation from russian)
----------------------------------
Program APACHE has caused an error while accessing memory page 
in module <unknown> at address 0000:00000013.
Registers:
EAX=00690d70 CS=0167 EIP=00000013 EFLGS=00010202
EBX=0066e77c SS=016f ESP=0063d998 EBP=00690af0
ECX=6ee07b70 DS=016f ESI=10004328 FS=6d0f
EDX=00690cb8 ES=016f EDI=78028c89 GS=0000
Bytes at address CS:EIP:
00 54 ff 00 f0 f8 7d 00 f0 16 e8 00 f0 00 00 00 
Stack:
0000000a 6ff0194e 0065a264 10004328 6ff01a90 10004328 0065a264 0063fbd8 10004328 6ff01b30 10004328 0065a264 10004328 6ff13b10 10004328 0065a264
-----------------------------------
As I found, 10004328 is an offset of imported from php4apache2.dll function "php4_module"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-01 14:19 UTC] sander@php.net
Can you provide a short sample script that causes this crash? 
 [2002-07-01 14:48 UTC] sniper@php.net
Use the STABLE snapshot and Apache 2.0.39. 
Other do not work. You should also know that Apache2
is very experimental atm. If you want to have stable
webserver, use Apache 1.3.26.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 12:05:53 2023 UTC