php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18020 Apache and PhP still not setting cookies
Submitted: 2002-06-27 10:12 UTC Modified: 2004-08-08 05:06 UTC
From: chris at thedions dot net Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chris at thedions dot net
New email:
PHP Version: OS:

 

 [2002-06-27 10:12 UTC] chris at thedions dot net
PhP and Apache2 are still not working together correctly to set those cookies.  I am using Apache 2.0.39 and PhP 4.2.2 Dev snapshot from 6-24-02.  I resubmitted this because you said that the problem was fixed .... it's not unless i'm doing something wrong.  My code is something like

if(blah){
blah blah blah
setcookie(cookie1, other values.......);
blah blah blah
}

if(blah){
blah blah blah
blah blah blah
setcookie(cookie2, other values.......);
setcookie(cookie3, other values.......);
blah blah blah
blah blah blah
}

Cookies 1 and 3 get set but not 2.  Cookies 2 and 3 do sit together like that in the code.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-27 10:33 UTC] chris at thedions dot net
the email got put in wrong it's chris@thedions.net so contact me there.
 [2002-06-27 13:04 UTC] derick@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

Fixed in the DEVelopment CVS (not the 4.2.x branch).

Derick
 [2002-08-20 01:16 UTC] xmadda at plasa dot com
its similiar with me, its not work in apache 2 (2.0.39) and php-4.2.2 OS XP. but in apache 1.3.26 its work.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 16:05:52 2022 UTC