php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18 get_browser() doesn't work.
Submitted: 1998-01-28 10:25 UTC Modified: 1998-01-28 12:09 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: fdeleau at comtech dot be Assigned:
Status: Closed Package: Other
PHP Version: 3.0b3 OS: Linux 2.0.33
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fdeleau at comtech dot be
New email:
PHP Version: OS:

 

 [1998-01-28 10:25 UTC] fdeleau at comtech dot be
I have php3.0b3 compiled as a module for Apache 1.2.5

The httpd process crashes (segmentation fault)when the 
following line is executed:
        
       <? $browser = get_browser(); ?>

The browscap.ini I'm using comes from http://php.netvision.net.il/browscap/

* My configure line:
--------------------

./configure --disable-debug --with-apache=/usr/src/apache_1.2.5 --with-mysql=/usr/src/mysql-3.21.18a-beta --with-config-file-path=/etc/httpd/conf --with-config-file=php3.ini

* In php3.ini, I have :
-----------------------

[browscap]
browscap = "/etc/httpd/conf/browscap.ini"


Regards,
Fabrice

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-01-28 12:09 UTC] zeev
The problem was that the regular expression libraries used by PHP and apache weren't the same.
get_browser() uses regex's, which caused the problem.
 [2013-12-24 12:19 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=ddf733fa6974e6ada3aec52005611f9b4647beb5
Log: Fixed #18 Errors not displaying in some configurations
 [2013-12-24 12:19 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=8064d8dfd6fc5a0433efcd5c38665c450f842888
Log: Fixed #18 Errors not displaying in some configurations
 [2013-12-24 12:20 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=ddf733fa6974e6ada3aec52005611f9b4647beb5
Log: Fixed #18 Errors not displaying in some configurations
 [2013-12-24 12:20 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=8064d8dfd6fc5a0433efcd5c38665c450f842888
Log: Fixed #18 Errors not displaying in some configurations
 [2013-12-24 21:07 UTC] ab@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=ddf733fa6974e6ada3aec52005611f9b4647beb5
Log: Fixed #18 Errors not displaying in some configurations
 [2013-12-24 21:07 UTC] ab@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=8064d8dfd6fc5a0433efcd5c38665c450f842888
Log: Fixed #18 Errors not displaying in some configurations
 [2014-10-28 21:16 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=36f487a32cb8b9d61bbcbc37c43b7a973dbcc7f8
Log: Fixed #18 Errors not displaying in some configurations
 [2014-10-28 22:00 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=36f487a32cb8b9d61bbcbc37c43b7a973dbcc7f8
Log: Fixed #18 Errors not displaying in some configurations
 [2014-10-29 14:34 UTC] jpauli@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=36f487a32cb8b9d61bbcbc37c43b7a973dbcc7f8
Log: Fixed #18 Errors not displaying in some configurations
 [2014-11-18 20:35 UTC] ab@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=36f487a32cb8b9d61bbcbc37c43b7a973dbcc7f8
Log: Fixed #18 Errors not displaying in some configurations
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC