php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17991 getlastmod() does not function with apache2filter SAPI
Submitted: 2002-06-26 06:57 UTC Modified: 2002-06-26 06:59 UTC
From: colmmacc at redbrick dot dcu dot ie Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: Confirmed on Solaris & Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: colmmacc at redbrick dot dcu dot ie
New email:
PHP Version: OS:

 

 [2002-06-26 06:57 UTC] colmmacc at redbrick dot dcu dot ie
getlastmod() and possibly other get_stat interfaces
to not appear to be functional with apache2filter sapi.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-26 06:59 UTC] derick@php.net
This is fixed in CVS< can you please try the latest non-stable snapshot from snaps.php.net?

Derick
 [2002-09-13 09:30 UTC] d dot p dot p at sympatico dot ca
In version 4.2.3 as well as in the latest snapshot, getlastmod() still appears not to be functional with apache2filter sapi (always returns false).
 [2002-11-13 07:44 UTC] mike at trinity dot unimelb dot edu dot au
I'm using Apache2 + php4.2.3 and getlastmod still doesn't work (14th November 2002). Noticed that some of the php doc pages also have this problem (they show 1/1/70 as lastmod). I'm using filemtime instead which works fine.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 07:05:53 2022 UTC