|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1798 Receiving no output
Submitted: 1999-07-21 10:00 UTC Modified: 1999-07-27 19:48 UTC
From: beppe at internode dot it Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Beta 1 OS: WinNT 4.0 SP5 It
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
34 + 15 = ?
Subscribe to this entry?

 [1999-07-21 10:00 UTC] beppe at internode dot it
Using Apache

I run php4 in a dos shell and no output when require() is used.
Even errors in script are skipped and even if required file is missing.
Also html data before script is not in output


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [1999-07-21 16:42 UTC] zeev at cvs dot php dot net
Are you running PHP interactively?
If you do, then code is no longer executed as you're typing.  Only after you end the script
(in UNIX, by pressing ctrl-D) the script gets executed.

You can run PHP interactively (i.e. execute each line of code as soon as it's written) by
running 'php -a'.

If that's not the issue, you should be able to prepare a short script that reproduces the
problem - it's really essential to help us figure what goes wrong here.

 [1999-07-26 06:26 UTC] beppe at internode dot it
Can't get any output (errors or correct data)
Sample script:

Simple output #1

echo( "Simpler output #2\n");

 [1999-07-26 17:28 UTC] zeev at cvs dot php dot net
You haven't answered me if you're using PHP interactively.
It seems that you are.
In Windows, you would have to press ^Z to stop writing the script
and start getting output.  Also, the binary that we distribute
for Windows does not support interactive mode, so -a won't help.
You would have to type up the entire script, and press ^Z-enter.

 [1999-07-27 19:48 UTC] beppe at internode dot it
I'm sorry, I thought it was clear, I wrote the previous script and saved it as test.php the I run "php test.php" from a dos shell under NT 4.0 and I got only the header output, no other data, if I remove the require(""); line it works fine.
It doesn't work even if I require an existing file.
If I go through Apache 1.3.6 for WinNT it's the same.
I tested it with the shell after I found it didn't work because I have an autoprepend in the ini file which uses requires.
If I eliminate the autoprepend statement my site could work but of course I have no required data so it's still a problem. I hope it's clearer now it was a script file and through the shell or apache I have no output if I use a require statement.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 04:01:24 2021 UTC