php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17974 setcookie with a variable in name don't work
Submitted: 2002-06-25 11:52 UTC Modified: 2002-06-25 13:40 UTC
From: obeaudet at videotron dot ca Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.2.1 OS: win32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: obeaudet at videotron dot ca
New email:
PHP Version: OS:

 

 [2002-06-25 11:52 UTC] obeaudet at videotron dot ca
I tried this command

$toto = "Temp";
setcookie("$toto[firstname]",$firstname);

and the cookie was not set but if I write this

setcookie("Temp[$toto]",$firstname);

it work

I found a workaround with this command

setcookie(setval($toto) . "[firstname]", $firstname);

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-25 13:40 UTC] sniper@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 27 23:03:33 2022 UTC