php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17962 var_unserializer.c:308: warning: comparison is always false due to limited ...
Submitted: 2002-06-25 03:58 UTC Modified: 2002-06-25 07:04 UTC
From: mw at suk dot net Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 4.0CVS-2002-06-25 OS: RedHat Linux 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mw at suk dot net
New email:
PHP Version: OS:

 

 [2002-06-25 03:58 UTC] mw at suk dot net
...

var_unserializer.c: In function `php_var_unserialize':
var_unserializer.c:308: warning: comparison is always false due to limited range of data type

...


configure line (although not needed in this case ...):

./configure \
        --prefix=/usr/server \
        --enable-bcmath \
        --enable-calendar \
        --enable-ftp \
        --enable-mbstring \
        --enable-sockets \
        --with-apxs2=/usr/server/bin/apxs \
        --with-config-file-path=/data/apache/conf \
        --with-mysql=/usr \
        --without-pear

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-25 07:04 UTC] sander@php.net
This is an autogenerated file (using re2c IIRC). We can't do much about this. Just ignore it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 08:01:25 2020 UTC