php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17933 PHP 4.2.1 on Apache 2.0.39
Submitted: 2002-06-23 05:56 UTC Modified: 2002-06-23 06:01 UTC
From: the0retic at webscript dot ru Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: Win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: the0retic at webscript dot ru
New email:
PHP Version: OS:

 

 [2002-06-23 05:56 UTC] the0retic at webscript dot ru
Hello everyone!
On Win32 PHP.4.2.1 not work with Apache.2.0.39.
This is a cmd line:
E:\usr\local\Apache2\bin>apache -t
apache: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not comp
atible with this version of Apache.
Please contact the vendor for the correct version.

Thanks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-23 06:01 UTC] derick@php.net
 **   ***   **   *  *
*  *   *   *  *  *  *
*      *   *     *  *
 **    *   * **  ****
   *   *   *  *  *  *
*  *   *   *  *  *  *
 **   ***   **   *  *

(we already got about 20 reports about this, hence the BIG warning on the bug reporting page).

Derick
 [2002-10-25 08:19 UTC] bob_cigogner at hotmail dot com
i've fgot the same problem, Apache2 don't wan't to start after the install of php-4.2.3 because "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" isnot compatible , but doesn't exist either in apache2 or php4, i founded 2 key in th registry 
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Explorer Bars\{C4EE31F3-4768-11D2-BE5C-00A0C9A83DA1}\ContainingTextMRU]
"000"="c:\\php4build\\snap\\sapi\\apache2filter\\sapi_apache2.c"

[HKEY_USERS\S-1-5-21-73586283-813497703-842925246-500\Software\Microsoft\Internet Explorer\Explorer Bars\{C4EE31F3-4768-11D2-BE5C-00A0C9A83DA1}\ContainingTextMRU]
"000"="c:\\php4build\\snap\\sapi\\apache2filter\\sapi_apache2.c"

and a texte search for "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" give php4apache2.dll

i had to install win2000 because only one computer, but i've already been infected because of security win apache 1.3 & 2000/NT, does noboddy know how to get php4 with Apache2 ??
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC