|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17887 unable to read complete data stream with set_socket_blocked($fp,0)
Submitted: 2002-06-20 17:55 UTC Modified: 2002-07-01 16:05 UTC
From: sdsdgdds at yahoo dot de Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.2.1 OS: Win XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
41 - 9 = ?
Subscribe to this entry?

 [2002-06-20 17:55 UTC] sdsdgdds at yahoo dot de
First of all I have to make a sleep() before I read data. Otherwise I don't receive any. It doesn't matter how long I sleep I allways get the same amount of data.

$ns = fsockopen("anyuri",80,$a,$a,$max);
fputs($ns,"GET / HTTP/1.1\r\nHost: anyuri\r\nConnection: close\r\n\r\n");
while(!feof($ns)) $out.=strtolower(fread($ns,128));	

and how do I get the rest?

I tried to make another sleep and fread but there comes nothing. Even if I made socket_set_blocking($ns,1); and tried to read the rest I received nothing.

Everything works fine if I don't use socket_set_blocking($ns,0);

I tried it on some big sites and the maximum was about 25000 bytes!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-01 16:05 UTC]
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at and the instructions on how to report
a bug at

feof() returns true on an error, and EWOULDBLOCK is considerd an error

PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 19:01:23 2021 UTC