php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1786 Previously working classes give divide by zero errors
Submitted: 1999-07-21 03:58 UTC Modified: 1999-09-02 20:26 UTC
From: jd at austin dot centergate dot com Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Beta 1 OS: linux2.2.25 (redhat)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jd at austin dot centergate dot com
New email:
PHP Version: OS:

 

 [1999-07-21 03:58 UTC] jd at austin dot centergate dot com
I didn't write this class, but it might help to find the bugs/changes in php4
that make it incompatible.

You can get the class at austin.centergate.com/networklog/class.graph

It gives the following errors in php4 (that it doesnt with php3).

Warning: Division by zero in class.graph on line 972
Warning: Division by zero in class.graph on line 1135
Warning: Division by zero in class.graph on line 1715

The generated graph doesnt plot any data but generates everything else.

In the mean time I've reverted to php3. 
Great job btw!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-07-31 14:44 UTC] zeev at cvs dot php dot net
The class file compiles properly, so I guess it's an execution problem.

Could you send me a small application of that class file that
reproduces the problem?
 [1999-09-02 20:26 UTC] zeev at cvs dot php dot net
No response from the user for a long while.  If the problem persists
with Beta 2 or later, please resubmit the bug report with more
information.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC