php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17838 getss not stripping <title>
Submitted: 2002-06-19 10:32 UTC Modified: 2002-07-04 03:50 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: rene at comunica2 dot net Assigned:
Status: Not a bug Package: Strings related
PHP Version: 4.1.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rene at comunica2 dot net
New email:
PHP Version: OS:

 

 [2002-06-19 10:32 UTC] rene at comunica2 dot net
I used fgetss to read and strip a regular html file which contained <title>bla bla </title>. It did not get stripped with the following: 

$buffer = fgetss($if, 4096,"<p><span><b><br><a><div>");

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 13:28 UTC] sniper@php.net
Seems to be fixed in CVS at least..I don't have 4.2.1 installed at the moment, but can you please try that first?

--Jani

 [2002-06-20 08:44 UTC] troels at arvin dot dk
I can't find any place in the CVS diffs/logs for file.c where the fgetss() function has been changed in a long time. Where would I find the fix?

I can reproduce the bug with PHP 4.2.1.
 [2002-06-20 18:44 UTC] sniper@php.net
Then try this snapshot:

http://snaps.php.net/php4-latest.tar.gz
 [2002-07-04 03:48 UTC] rene at comunica2 dot net
Hay guys, I appologize about this bug report. I was mistaken. This function only strips tags, not the content of the tag. When I said it did not strip the tag, I was wrong. I does strip the title tags and nicely leaves the text that was surrounded by them. The thing is that I wanted the text to be removed and of course that won't happen with this function. Sorry for the false alarm and the time lost. I discovered this when I was looking at other HTML filters and the same thing happened of course!
 [2002-07-04 03:50 UTC] derick@php.net
User error -> bogus
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 16 12:01:23 2019 UTC