php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17837 PHP 'handles' permission problems rather than letting Apache do it
Submitted: 2002-06-19 09:49 UTC Modified: 2002-07-24 07:29 UTC
From: acm at tweakers dot net Assigned:
Status: Wont fix Package: Apache related
PHP Version: 4.2.1 OS: Linux, various
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: acm at tweakers dot net
New email:
PHP Version: OS:

 

 [2002-06-19 09:49 UTC] acm at tweakers dot net
The bug is the same as: http://bugs.php.net/bug.php?id=8638
But is still there in php-4.2.1 and 4.1.2 on various apache/linux platforms.

Try this:
Create a .php-file with chmod 644, open it in your browser.
It'll work.
chmod it to 000, and you'll give you a "Warning: Failed opening '/path/to/file.php' for inclusion (include_path='') in Unknown on line 0"

Then try a .html-file, chmod 644, chmod 000 etc.
Will give a nice 403 error message.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-19 09:53 UTC] negotiator at tweakers dot net
I'm experiencing exact the same problem in a Windows 2000 Server / IIS 5.0  environment.
 [2002-07-24 07:29 UTC] hholzgra@php.net
expected behavior
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 20 16:01:26 2019 UTC