php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17775 bug search page is counterproductive
Submitted: 2002-06-15 16:57 UTC Modified: 2002-06-16 12:06 UTC
From: adam at adeptsoftware dot com Assigned:
Status: Not a bug Package: Website problem
PHP Version: 4.2.1 OS: NA
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adam at adeptsoftware dot com
New email:
PHP Version: OS:

 

 [2002-06-15 16:57 UTC] adam at adeptsoftware dot com
The bug search page is severely crippled by the fact that it searches by OR not AND.  It won't even search for "phrases in quotes".

Also, one of the main points of the bug search page is avoiding duplicates.  To that end, the "status" box should default to "all" not "open".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 07:56 UTC] sander@php.net
Mainly a dupe of #17391, but I don't know what to do with your proposal to change the status box to default to all...
 [2002-06-16 08:01 UTC] goba@php.net
It's default is open, because we encourage guys
submitting bug reports to search for similar bugs
before submitting the report. It's obvious that the
default then should be Open, and not All...

BTW the other user group of the bug system, the "bug
hunters" also search in open bug reports, they are not
interested in other types most of the time IMHO...

Goba
 [2002-06-16 12:06 UTC] adam at adeptsoftware dot com
A similar bug could exist in a "closed" or "bogus" state.
It's obvious to some that if you're searching for duplicates you want to search ALL bugs, not just ones that haven't been looked at yet.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 13:05:53 2022 UTC