|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17736 After install php 4.2.1, Apache couldn't start
Submitted: 2002-06-13 02:25 UTC Modified: 2002-06-13 17:42 UTC
From: stevenleong at yahoo dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: Redhat Linux 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
42 + 45 = ?
Subscribe to this entry?

 [2002-06-13 02:25 UTC] stevenleong at yahoo dot com
  Currently,  I installed Apache 2.0.36 as my DSO web server.  I tried to upgrade my current php 4.1.2-7 to php 4.2.1.  I used the following comment to install
>./configure --with-mysql --with-apxs2=/usr/local/apache-2.0.36/bin/apxs
>make install

Then I copied php.ini-dist to /etc/php.ini

Then I tried 
>apachectl start
>Syntax error on line 253 of /usr/local/apache-2.0.36/conf/httpd.conf:
Cannot load /usr/local/apache-2.0.36/modules/ into server: /usr/local/apache-2.0.36/modules/ undefined symbol: core_globals_id
/usr/local/apache-2.0.36/bin/apachectl start: httpd could not be started

I didn't understand why core_globals_id related to this php.

Please let me know as soon as possible if you find a solution.

I appreciate it.



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-13 09:13 UTC]
Please try the latest CVS snapshot of PHP:

 [2002-06-13 13:51 UTC] stevenleong at yahoo dot com
After installed the latest snapshot, I got this error when running apachectl start

[root@dev php]# $APACHE_HOME/bin/apachectl start
Syntax error on line 265 of /usr/local/apache-2.0.36/conf/httpd.conf:
Invalid command 'AddModule', perhaps mis-spelled or defined by a module not included in the server configuration
/usr/local/apache-2.0.36/bin/apachectl start: httpd could not be started

I looked at httpd.conf
There are two lines added.
LoadModule php4_module        modules/
AddModule mod_php4.c

Did I miss something in Apache 2?  How come it doesn't recognize AddModule?
Do you have any idea?

 [2002-06-13 15:21 UTC]
It's not a Apache2 configuration directive. Just remove it.

 [2002-06-13 17:42 UTC] stevenleong at yahoo dot com
I removed AddModule mod_php4.c and it works fine.  I will try to test more ...

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 14:01:32 2024 UTC