php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17709 php_mssql cannot be found
Submitted: 2002-06-11 13:51 UTC Modified: 2002-09-11 11:17 UTC
From: juts at atlantic dot net Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.2.1 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: juts at atlantic dot net
New email:
PHP Version: OS:

 

 [2002-06-11 13:51 UTC] juts at atlantic dot net
When I tried to load the php_mssql.dll file, it could not be found.  I know its the correct location as php_pdf.dll as well as a couple others load just fine.  When I switched IIS to use isapi instead of php.exe, it loaded correctly and is working now.

This is definitely a bug and not a support issue.  Please look into it.

Thank you.
Justin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-11 13:56 UTC] mfischer@php.net
php_mssql.dll depends on ntwdblib.dll , are you sure you have this one in your %PATH% ?
 [2002-06-11 14:42 UTC] juts at atlantic dot net
"%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32;C:\PHP\dlls" is the content of my %PATH% env var where "C:\PHP\dlls" is the default dlls folder.  I also tried to copy the dll's directly to SystemRoot\system32 to no avail.

Thanks,
Justin
 [2002-06-11 14:44 UTC] sander@php.net
I'm not sure ntwdblib.dll is distributed with PHP. Are you sure it's in some of those directories?
 [2002-06-11 14:50 UTC] juts at atlantic dot net
ntwdblib.dll is present in the PHP/dlls folder.  It appears to have been added to the distribution.
 [2002-06-11 18:48 UTC] sniper@php.net
Any of php developers got XP to test this with?
(I doubt this is a bug in PHP but in XP and/or misconfiguration)

 [2002-06-11 20:33 UTC] juts at atlantic dot net
Hey all,

Just to make sure I wasn't losing my mind, I tried the same thing on my box at home (running XP pro as well) and got the exact same error.  Weird eh.

Thanks,
Justin
 [2002-07-07 21:52 UTC] sniper@php.net
Does this happen with this snapshot build:

http://snaps.php.net/win32/php4-win32-latest.zip

 [2002-09-11 11:17 UTC] sniper@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 15:01:28 2024 UTC