php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17685 Warnings at end of compile and installation hanging
Submitted: 2002-06-10 18:17 UTC Modified: 2002-06-26 12:59 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: neil at mpfreescene dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0CVS-2002-06-10 OS: FREEBSD 4.5-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: neil at mpfreescene dot com
New email:
PHP Version: OS:

 

 [2002-06-10 18:17 UTC] neil at mpfreescene dot com
Im getting these errors whilst compiling ever since PHP 4.2.1, I have had to upgrade from PHP 4.2.1 due to the multiple cookie setting bug.

ext/mysql/libmysql/my_tempnam.lo: In function `my_tempnam':
/root/php4/ext/mysql/libmysql/my_tempnam.c(.text+0x51): warning: tempnam() possibly used unsafely; consider using mkstemp()
/usr/lib/libc.so.4: WARNING!  setkey(3) not present in the system!
/usr/lib/libc.so.4: warning: this program uses gets(), which is unsafe.
/usr/lib/libc.so.4: warning: mktemp() possibly used unsafely; consider using mkstemp()
/usr/lib/libc.so.4: WARNING!  des_setkey(3) not present in the system!
/usr/lib/libc.so.4: WARNING!  encrypt(3) not present in the system!
/usr/lib/libc.so.4: warning: tmpnam() possibly used unsafely; consider using mkstemp()
/usr/lib/libc.so.4: warning: this program uses f_prealloc(), which is not recommended.
/usr/lib/libc.so.4: WARNING!  des_cipher(3) not present in the system!
su-2.05a#


And when I try to install the compiled package, it hangs when it trys to do this command :-

/root/php4/sapi/cli/php /root/php4/pear/install-pear.php /root/php4/pear/package-*.xml

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-10 20:10 UTC] sniper@php.net
I guess those warnings can safely be ignored..but that pear install stuff might not work as expected..

 [2002-06-15 16:39 UTC] neil at mpfreescene dot com
What does this mean to me, do you think it is a bug, the latest CVS is still giving me exaclty the same problem in that when it tries to install the pear function it just hangs and I ahve to send a kill signal.
 [2002-06-15 19:48 UTC] sniper@php.net
What was the configure line used to configure PHP?


 [2002-06-16 07:56 UTC] neil at mpfreescene dot com
I used the following configure string, the command it hangs on is also shown below :-

./configure --with-mysql --with-apxs2=/usr/local/apache/bin/apxs --with-tsrm-pth=/usr/local/bin/pth-config

The following is the last two commands run from 'make install' it runs the last command and the system just hangs, I have to send kill signal to it :-

/root/php4/build/shtool install -c -m 0755 sapi/cli/php /usr/local/bin/php
/root/php4/sapi/cli/php /root/php4/pear/install-pear.php /root/php4/pear/package-*.xml
 [2002-06-21 15:38 UTC] thiago at rnp dot br
A solution for this problem in my case, was edit Makefile and remove all "-pthreads" entries!

---thiago/rnp
 [2002-06-26 12:07 UTC] neil at mpfreescene dot com
I think this bug may be fixed now.

I have uprgaded to FREEBSD4.6, Apache 2.0.39 and the latest CVS of php and it now works fine.

I should have tested it whilst still on FREEBSD4.5.
 [2002-06-26 12:59 UTC] derick@php.net
Closing then...
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 11:01:30 2024 UTC