php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17645 problem in variables using between html and php
Submitted: 2002-06-07 12:18 UTC Modified: 2002-06-07 12:35 UTC
From: ritaceresi at tiscalinet dot it Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.2.1 OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ritaceresi at tiscalinet dot it
New email:
PHP Version: OS:

 

 [2002-06-07 12:18 UTC] ritaceresi at tiscalinet dot it
We have installed an apache 1.3.19 recompiled with the activation of php
4.2.1 module on AIX 4.3.3. The php mainly works because if we have a php
file it is correctly interpreted.
The problem arises when we try to capture a variable value from a html form
and we try to use the value of that variable: it seems that the value is
lost. We run the same example to Linux platform instead of AIX and it works
fine!
Here the simple test we perform:
=======================
File test.html

<html>
<body>
prova
<form name="test" method="post" action="risposta.php">
<input type="text" name="campo" size=15 maxlength=8>
<input type="submit" name="invia">
</form>
</body>
</html>


File risposta.php

<?PHP
        echo "E' stato inviato:<br>";
        echo "--->" . $campo . "<---<br>";
?>

The result was:

The result is :

E' stato inviato:

---><---

Any idea?? 
Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-07 12:30 UTC] mitja at doticni dot net
You would need to have register_globals enabled, which is probably the problem.

http://www.php.net/manual/en/configuration.php#ini.register-globals
 [2002-06-07 12:35 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 05:01:30 2024 UTC