php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17600 imap_open doesn't connect
Submitted: 2002-06-04 17:05 UTC Modified: 2002-06-04 17:52 UTC
From: ajep22 at yahoo dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.2.1 OS: RedHat 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ajep22 at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-06-04 17:05 UTC] ajep22 at yahoo dot com
I tried a lot of connection string... i'm crazy now. really.

The log said: (with every string i try...)

Jun  4 16:48:09 server imapd[1704]: imap service init from 10.1.1.1
Jun  4 16:48:11 server imapd[1704]: Command stream end of file, while reading line user=??? host=UNKNOWN

and php said:

Warning: Couldn't open stream {10.1.1.1:143} in /var/www/html/webmailtest/login.php on line 3

so... please somebody help me :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-04 17:52 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-06-11 09:00 UTC] hilbert_mostert at hotmail dot com
Hello,

I am experiencing the same problem on RedHat 7.3 with PHP 4.2.1 and Imap support, RH 7.3 uses c-client version 2001a 

My system is a PII-400 with 320 Megabytes of ram
RedHat 7.3, 
php-4.2.1, 
apache 1.3.23,
and imap c-client version 2001a

This is all the info i can give, there are no more error messages.
The imap server itself works correctly when using other e-mail clients.

Sindcerely,

Hilbert
 [2002-06-17 18:44 UTC] vince at sixpak dot org
Add /notls to the connection string.
 [2002-06-23 13:54 UTC] theodore at mts dot net
I have exactly the same problem on redhat 7.2 with updated imap-2001a packages...

My system is a duron 650 with 384 MB of RAM
RedHat 7.2
php-4.2.1 
apache 1.3.26
and imap c-client version 2001a

php config as follows:

System Linux linux 2.4.9-31 #1 Tue Feb 26 06:23:51 EST 2002 i686 unknown 
Build Date Jun 22 2002 19:54:03 
Configure Command './configure' '--quiet' '--with-apxs=/usr/local/apache/bin/apxs' '--with-mysql' '--enable-track-vars' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--enable-ftp' '--enable-sockets' '--with-gettext' '--with-mm=../mm-1.1.3' '--with-zlib' '--enable-exif' '--with-gd=/home/theodore/compile/gd-2.0.1/' '--with-jpeg-dir=/usr' '--with-zlib-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-tt' '--enable-mbstring' 
Server API Apache 
Virtual Directory Support disabled 
Configuration File (php.ini) Path /usr/local/lib/php.ini 
Debug Build no 
Thread Safety disabled 



everything else in php works fine... except for using the imap module to connect to an imap server (it works to connet to a pop server) 

i also get the following lines in /var/log/maillog 

Jun 23 12:43:26 linux imapd[8070]: imap service init from 192.168.0.2
Jun 23 12:43:26 linux imapd[8070]: Command stream end of file, while reading line user=??? host=UNKNOWN
 [2003-04-11 06:49 UTC] marc dot bartel at bacomdesigns dot de
I had the same problem, but now it works with 
/notls
BUT WHY ???
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Sep 26 23:05:52 2022 UTC