php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1753 httpd segfaults when compiled --with-mysql
Submitted: 1999-07-20 12:27 UTC Modified: 2007-04-26 09:31 UTC
From: joey at samaritan dot com Assigned: jah (profile)
Status: Not a bug Package: *General Issues
PHP Version: 4.0 Beta 1 OS: debian linux 2.1 (2.0.36 kernel)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joey at samaritan dot com
New email:
PHP Version: OS:

 

 [1999-07-20 12:27 UTC] joey at samaritan dot com
./configure --with-apache=/usr/src/apache --with-sybase=/usr/local/sybase --with-mysql 
--with-ldap --with-imap --with-dbase=yes --with-filepro=yes  --with-zlib 
--enable-sysvshm=yes --enable-sysvsem=yes --with-config-file-path 
--enable-track-vars=yes --enable-magic-quotes=yes 
--enable-debugger=yes --enable-bcmath=yes


% gdb ./httpd

Program received signal SIGSEGV, Segmentation fault.
0x40059e9e in db.init_charset ()
(gdb) bt

#0  0x40059e9e in db.init_charset ()
#1  0x4005c64e in dbopen ()
#2  0x40234817 in   ()
#3  0x402349f1 in   ()
#4  0x40234c51 in   ()
#5  0x401f6456 in getservbyname_r ()
#6  0x401f62c2 in getservbyname ()
#7  0x80a4783 in OnMySQLPort (entry=0x8217990, new_value=0x0, new_value_length=3, mh_arg1=0x0, mh_arg2=0x0, mh_arg3=0x0)
    at mysql.c:242
#8  0x80935e1 in php_register_ini_entries (ini_entry=0x81d4e98, module_number=20) at php_ini.c:113
#9  0x80a47ec in php3_minit_mysql (type=1, module_number=20) at mysql.c:285
#10 0x80d6c9f in zend_startup_module (module=0x81d4e68) at zend_API.c:539
#11 0x808fb04 in module_startup_modules () at internal_functions.c:119
#12 0x808f2bd in php_module_startup (sf=0x81d179c) at main.c:843
#13 0x808e75b in php_init_handler ()
#14 0x80f3889 in ap_init_modules ()
#15 0x80fec3d in main ()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-07-30 12:34 UTC] joey at samaritan dot com
#5  0x401f6456 in getservbyname_r 

debian gnu/linux does not support getservbyname_r.
 [1999-07-30 13:23 UTC] joey at samaritan dot com
#5  0x401f6456 in getservbyname_r 

debian gnu/linux does not support getservbyname_r.
 [1999-07-31 19:23 UTC] jah at cvs dot php dot net
This is a known problem and is caused by both /where/your/sybase/libs/are/libsybdb.so
and /lib/libnss_db.so (or something like it) containing function
dbopen. Nothing we can do when there's a symbol clash between
libraries.

If my memory servers me right, a workaround is to disable db
for services in /etc/nsswitch.conf (ie., there should be a
line in that file that says: 'services: files'. If that line
is 'services: db files', remove that db and restart nis. If
even that doesn't work, try stopping nis altogether.)

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC