php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17515 Repeatedly calling the mail function does not work.
Submitted: 2002-05-29 16:43 UTC Modified: 2002-06-02 18:15 UTC
From: barbecue at zonnet dot nl Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.2.0 OS: Windows2000 and WindowsXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: barbecue at zonnet dot nl
New email:
PHP Version: OS:

 

 [2002-05-29 16:43 UTC] barbecue at zonnet dot nl
When calling the mail-function repeatedly, very quickly, only one in ~15 mails will actually be sent. However, the mail function returns true.

This is on my local development machine, as well as on the servers at my internet-hosting-provider.

I am using the SMTP service of Internet Information Server.

When I do a 'Sleep(1)' between every call to the mail-function, all mails are properly sent.

Regards,
Peter.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-02 18:15 UTC] mfischer@php.net
This is a problem of your MTA, I can send 1000 of mails here without any delay and not miss a single one.

However, you still may try a snapshot from http://snaps.php.net/win32/ (NOT the stable ones)
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 11:03:46 2023 UTC