php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17501 receiving "access violaton error"
Submitted: 2002-05-29 02:12 UTC Modified: 2002-05-29 03:41 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: ekotov at bmc dot com Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.2.1 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ekotov at bmc dot com
New email:
PHP Version: OS:

 

 [2002-05-29 02:12 UTC] ekotov at bmc dot com
Hello,
I am working with php version 4.2.1 , IIS 5.0, Windows 2000.
I configured my IIS server using php4isapi.dll.
After number of refreshes I receive:
"Php has encountered an Access Violation at 01010290E".
Since that I have to restart my IIS server in order
to continue a work.
I saw the similar problem with php , version 4.0.
I hoped that the upgrade to 4.2.1 will solve this problem,
but it doesn't.
This problem doesn't occure working with php.exe.
If you have any work around to this problem or 
other version of php that doesn't have this problem,
please send it to me.
Thanks,
Elena.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-29 03:41 UTC] mfischer@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-07-24 17:16 UTC] tony_ansley at dell dot com
Software:

Win2K SP2 All security updates
PHP 4.2.1 and 4.2.2 have been tried


Hardware:

P4 1.8GHz
384MB RAM
30GB HD (no storage limitations)

What I did:

Configured new OS on system specifically for this testing
Installed PHP 4.2.1  (installation checked by running phpinfo())
Installed phpBB2

Scenario1:

Open IE5.5, go to phpbbhome, login to phpbb, once logged in, I let system sit for anywhere from 5-30 minutes (cannot determine actual time needed or if it is number of pages loaded).  Eventually, browser will "spin" trying to load the page.  This load event goes on for some time, the longest I have let it go before stopping is 15-20 minutes.  If I stop and then try to refresh to start the load again, but again it will fail.  I repeatedly press the refresh and eventually I will get "PHP has encountered an Access Violation at 010129AE".  

Scenario 2:

Load phpinfo(), and repeatedly refresh allowing the page to complete before refreshing again.  Eventually, I will get "PHP has encountered an Access Violation at 010129AE"

I have to restart IIS service to get php to respond again.

Thanks
Tony Ansley
Sr. Consultant
Dell Professional Services
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 13:01:27 2020 UTC