php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17493 Undefined Symobl: pthread_getspecific when starting Apache
Submitted: 2002-05-28 15:57 UTC Modified: 2002-06-13 09:49 UTC
From: thuresson at coe dot tsuniv dot edu Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.0CVS-2002-05-28 OS: FreeBSD 4.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: thuresson at coe dot tsuniv dot edu
New email:
PHP Version: OS:

 

 [2002-05-28 15:57 UTC] thuresson at coe dot tsuniv dot edu
Sorry for posting this under FreeBSD 4.1.1/PHP 4.2.1

I successfully compiled Apache 2.0.36/PHP 4.3.0 dev on RedHat 7.2
Apache
./configure --prefix=/usr/local/apache2 --enable-modules=most
--enable-so

PHP
./configure --prefix=/usr/local/php430 --enable-ftp
--with-apxs2=/usr/local/apache2/bin/apxs

httpd.conf
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php

I failed similar to previous comments when trying to install it the same
way on FreeBSD 4.4

./apachectl start
Syntax error on line 230 of 
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into 
server: /usr/local/apache2/modules/libphp4.so: Undefined 
symbol "pthread_getspecific"
./apachectl start: httpd could not be started


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-13 09:49 UTC] sniper@php.net
See bug: http://bugs.php.net/?id=14594 which has good
explanation what the problem is and how to solve it.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 22:03:37 2021 UTC