php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17481 call to undefined function socket
Submitted: 2002-05-28 06:49 UTC Modified: 2002-05-28 06:54 UTC
From: office at iworks dot at Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.1.2 OS: Windows 2000 Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: office at iworks dot at
New email:
PHP Version: OS:

 

 [2002-05-28 06:49 UTC] office at iworks dot at
i'm using the php 4.1.2 win-installer on win2000 and have added php_sockets.dll to the extensions-directory afterwards.
i've set the extension in my php.ini and phpinfo() tells me "socket support enabled", but if i try to call socket() it always returns the same error: "call to undefined function: socket() in..."

i've searched the bug-db but i found no solution resp. to my configuration.

tuvm

michael

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-28 06:54 UTC] mfischer@php.net
The old interface has gone. They're now called socket_*(), e.g. socket_create(), etc.

See php.net/sockets
 [2002-05-28 10:35 UTC] office at iworks dot at
thank you!

i just used socket() because of the example-script on the first page of the socket ref., but with the socket_*() it works pretty well...

thanks michael
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 23:01:24 2020 UTC