php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17475 results of Virtual() is misplaced
Submitted: 2002-05-28 05:17 UTC Modified: 2002-05-30 07:08 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: rich_mcanir at yahoo dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: WinXP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rich_mcanir at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-05-28 05:17 UTC] rich_mcanir at yahoo dot com
This problem can be explained really simple with a script. And I am sure it's a problem with Apache2 because this problem doesn't arise in Apache. (Note: the content of ip.cgi and ip.html is simply IP.CGI and IP.HTML respectively.)

The Code:
<P>1. <?php virtual("ip.cgi")?>
<P>2. <?php virtual("ip.html")?>

Output (Apache2):
IP.NETIP.HTML
<P>1. <P>2. 

Output (Apache):
<P>1. IP.NET<P>2. IP.HTML

In conclusion, the content prased by virtual() is misplaced.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-28 11:28 UTC] sander@php.net
You don't happen to have different ob_* settings for both servers? IIRC, virtual() doesn't wrap through the output buffering system.
 [2002-05-28 12:15 UTC] rich_mcanir at yahoo dot com
Both servers use the same setting since they are both on the same computer. All settings are default. Of course, one uses php4apache2.dll and the other uses php4apache.dll. I don't understand any strange behaviour.
 [2002-05-30 02:02 UTC] rich_mcanir at yahoo dot com
The problem has been solved by replacing the php.ini with a new fresh one.
 [2002-05-30 07:08 UTC] sniper@php.net
user error -> bogus.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 00:01:31 2024 UTC