php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17471 Problem with Novell Netware map drive
Submitted: 2002-05-28 04:28 UTC Modified: 2002-10-25 01:00 UTC
Votes:6
Avg. Score:4.5 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:2 (50.0%)
From: alex at consultant dot ru Assigned:
Status: No Feedback Package: *Directory/Filesystem functions
PHP Version: 4.2.1 OS: Windows 2000 Prof
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alex at consultant dot ru
New email:
PHP Version: OS:

 

 [2002-05-28 04:28 UTC] alex at consultant dot ru
Sorry for my English.
I have some problems with filesystem functions in case of working with Novell Netware map drive:

<?
$result=file("H:/DIR/list.txt");
?>

where H: - Novell Netware map drive.

This construction returns: No such file or directory.
Other directory and filesystems functions returns same result, when trying connect to Novell Network drive :(
Under Windows 98 this working correctly

Running software:
Windows 2000 Prof
Apache 1.3.20
PHP 4.2.1
Novell Client 4.81
Novell Netware 5.0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-03 02:33 UTC] k.schroeder@php.net
Do you running Apache in console or as service?

If you running Apache as service, normaly the rights of user "SYSTEM" would used. Please check, if "SYSTEM" has the rights to access the files.

Regards, Kai
 [2002-06-04 02:38 UTC] alex at consultant dot ru
I'm running Apache under admin rights...
That's not a problem whith rights (i'm sure).
 [2002-06-21 12:23 UTC] cg at gordimer dot net
You must use a network user with access rights to the novell mapping (run Apache IIS with that user)

Then it should work - at least it does in my case.

Christoph
 [2002-10-09 11:28 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 20:03:36 2021 UTC