php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17465 GMP function output garbage.
Submitted: 2002-05-27 18:54 UTC Modified: 2002-07-07 13:19 UTC
From: llucar at mecon dot gov dot ar Assigned:
Status: Closed Package: Math related
PHP Version: 4.1.2 OS: Debian GNU/Linux unstable
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: llucar at mecon dot gov dot ar
New email:
PHP Version: OS:

 

 [2002-05-27 18:54 UTC] llucar at mecon dot gov dot ar
Hi, I'm using GMP funtions, and I have a problem.
The problem is this:
var_dump( gmp_strval( '64' ) );
and I get:
string (3) "64<null>"
where <null> is the null character (\0x00).

I'm using Debian's GNU/Linux sid (unstable) source package to compile it, just adding GMP support to it.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-07 13:19 UTC] derick@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 22 16:03:35 2022 UTC