php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17446 missing POST-Variables using Apache2 on WinXP
Submitted: 2002-05-27 02:23 UTC Modified: 2002-05-27 03:27 UTC
From: dirk at ministry dot de Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.1 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dirk at ministry dot de
New email:
PHP Version: OS:

 

 [2002-05-27 02:23 UTC] dirk at ministry dot de
Just installed the latest Version of Apache2, PHP and MySQL and tried a simple login-script. I found out that the input-fields "user" and "pass" did not get posted as variables $user and $pass but I had to use $HTTP_POST_VARS['user'] and $HTTP_POST_VARS['pass'].

Further more I found out that this could also be an Apache2-Bug, but it should have been fixed some time ago - do not know if the distributed win32-binaries on apache.org got updated though...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-27 03:27 UTC] sander@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 15:03:51 2022 UTC