php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17418 if statment not working?
Submitted: 2002-05-24 16:04 UTC Modified: 2002-05-24 16:32 UTC
From: ferguson at becon dot org Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.2.1 OS: win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ferguson at becon dot org
New email:
PHP Version: OS:

 

 [2002-05-24 16:04 UTC] ferguson at becon dot org
I belive this is a bug but i could be wrong because i find it hard to belive the the if statment would not be wroking.

$YesMen ='1';
if ($YesMen == '2')echo "This means No";
else echo "This means Yes";
//returnes "This means Yes";

$YesMen ='1';
if ($YesMen == '1')echo "This means No";
else echo "This means Yes";
//returnes "This means Yes"

if ($YesMen == 'sldkw984pruowiefjow48r')echo "This means No";
else echo "This means Yes";
//returnes "This means Yes";

$YesMen =1;
if ($YesMen == 'sldkw984pruowiefjow48r')echo "This means No";
else echo "This means Yes";
//returnes "This means Yes";

$YesMen =2;
if ($YesMen == '2')echo "This means No";
else echo "This means Yes";
//returnes "This means No";

It this acting properly?

Brendan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-24 16:32 UTC] mfischer@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 19:01:30 2024 UTC