php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17408 fail to connect oracle
Submitted: 2002-05-24 08:56 UTC Modified: 2002-05-24 09:07 UTC
From: teerayuk at ais900 dot com Assigned:
Status: Not a bug Package: Oracle related
PHP Version: 4.1.2 OS: WIN2000 AD Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: teerayuk at ais900 dot com
New email:
PHP Version: OS:

 

 [2002-05-24 08:56 UTC] teerayuk at ais900 dot com
Hello,
   I upgrade my server from NT -> 2000 and php 4.04pl -> 4.12 because i test with 4.21 and it's not work good. i have very problem with php in the upgrade process such as "access encounter at ..." and i read suggestion in the net to use cgi version instad of isapi version. When i do that, it's nearly good but i founds another problem about oracle connection (in isapi it works good).

my code is :

putenv("ORACLE_SID=XXX"); 
putenv("ORACLE_HOME=e:\orant"); 
putenv("TNS_ADMIN=e:\orant\network\admin"); 

ora_logon($this->sqluser,$this->sqlpass);

it's not work!! and return error

Oracle: Connection Failed: ORA-12154: TNS:could not resolve service name 

i don't understand because i assigned ORACLE_HOME & TNS_ADMIN already 

when i use phpinfo() it return 

         oracle
Oracle Support                 enabled 


        Environment
             .
             .
             .
ORACLE_SID     acid1 
ORACLE_HOME   e:\orant 
TNS_ADMIN     e:\orant\network\admin 

variable that i assign is in environment section. it's the bug or not. And how can i do.  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-24 09:07 UTC] mfischer@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 04:01:30 2024 UTC