php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17368 Warning: file("http://www.php.net") - Bad file descriptor in /var/www/.....
Submitted: 2002-05-22 15:49 UTC Modified: 2002-05-22 15:51 UTC
From: jmartone at cognitivesolutions dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 4.0CVS-2002-05-22 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jmartone at cognitivesolutions dot com
New email:
PHP Version: OS:

 

 [2002-05-22 15:49 UTC] jmartone at cognitivesolutions dot com
The code below works fine, I have it running on a Redhat Linux 7.1 machine with PHP 4.04pl1.  The problem is that it does not work on a Cobalt Raq4i with PHP 4.03pl1 or PHP 4.06.  I have checked Cobalt's website for any info regarding this issue but have found nothing, just links back to www.php.net  Does anyone know where the problem lays?

Thank You


<?

//open a file and print each line
$myFile = file ("http://www.php.net");
for ($index = 0; $index < count($myFile); $index++)
    {
	print ($myFile[$index]);
    }
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-22 15:51 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 09:01:26 2019 UTC