php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17361 Can't evaluate variables
Submitted: 2002-05-22 10:39 UTC Modified: 2002-05-22 10:47 UTC
From: p dot pervoy at bt-entel dot kiev dot ua Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.2.1 OS: Win2000 adv server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: p dot pervoy at bt-entel dot kiev dot ua
New email:
PHP Version: OS:

 

 [2002-05-22 10:39 UTC] p dot pervoy at bt-entel dot kiev dot ua
We had Win Nt 4.0 server with apache 1.3 and php 4.0. Everything worked perfect, but after installing new OS - Win2k we reinstalled php and apache (was as CGI module, now as ISAPI) and the nex problem apeared:

when trying to access page with params

foo.php?param1=val1

the php doesn't accept param1 (I mean isset(param1) returns 0)

I tryed to fix it by reinstalling php as cgi (in documentation it's said that there are some problems with ISAPI), but nothing changed...

WHAT SHOULD I DO?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-22 10:47 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 23 07:01:23 2021 UTC