php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17332 easter_date()
Submitted: 2002-05-21 05:27 UTC Modified: 2002-05-21 05:30 UTC
From: Martin dot Schmitz at Uni-Bielefeld dot de Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 4.2.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Martin dot Schmitz at Uni-Bielefeld dot de
New email:
PHP Version: OS:

 

 [2002-05-21 05:27 UTC] Martin dot Schmitz at Uni-Bielefeld dot de
Hi developers,

1) the easter functions doesn't work (in older versions you have to compile it with dl/calendar, but in newer versions it should be included (as it is written in the docu).

2) if a variable isn't defined it is '1' after you increment it.

e.g:

while($i <= 10){
  echo 'Value = '.any_array[$i];
  $i++;
}

any_array[0] will not be displayed, because it wasn't defined like "$i = 0;" in top of the loop. But if isn't '0', it shouldn't be '1' if you increment it. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-21 05:30 UTC] derick@php.net
Please open a new, more detailed bugreport for the easter_date 'bug'

And 2) is not a bug, the value of an uninitialized variable is NULL (not 0).

Derick
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 21 09:01:23 2020 UTC