php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17325 PHP Fails to run when using Apache 2.036, unresolved symbols
Submitted: 2002-05-20 21:09 UTC Modified: 2002-06-13 09:48 UTC
Votes:8
Avg. Score:5.0 ± 0.0
Reproduced:8 of 8 (100.0%)
Same Version:8 (100.0%)
Same OS:6 (75.0%)
From: webmaster at vdhosting dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: FREEBSD 4.1.1 STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
47 + 43 = ?
Subscribe to this entry?

 
 [2002-05-20 21:09 UTC] webmaster at vdhosting dot com
I compiled standard Apache-2.0.35, then downloaded 
php-4.2.1, compiled it just with --with-mysql and 
--with-apxs2=/usr/local/apache2/bin/apxs

After sucessful make install, I tried to run 
/usr/local/apache2/bin/httpd, which resulted in this error:

Syntax error on line 177 of 
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into 
server: /usr/local/apache2/modules/libphp4.so: Undefined 
symbol "pthread_getspecific"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-22 07:44 UTC] stimpy at broekiemedia dot nl
I'm using FreeBSD 4.5, Apache-2.0.35 for freebsd 4.5,
mysql-3.23.49-unknown-freebsdelf4.4-i386

I compiled with --with-mysql=/usr/local/mysql
--with-apxs2=/usr/local/apache2/bin/apxs

httpd.conf contains:
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php

And also I get this error:
Failed to start apache : 
Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/usr/local/apache2/modules/libphp4.so: Undefined symbol
"pthread_getspecific"
/usr/local/apache2/bin/apachectl start: httpd could not be started


I also posted this reply at http://bugs.php.net/bug.php?id=14594, but then I found out it was closed...
 [2002-05-28 15:41 UTC] thuresson at coe dot tsuniv dot edu
I successfully compiled Apache 2.0.36/PHP 4.3.0 dev on RedHat 7.2
Apache
./configure --prefix=/usr/local/apache2 --enable-modules=most --enable-so

PHP
./configure --prefix=/usr/local/php430 --enable-ftp --with-apxs2=/usr/local/apache2/bin/apxs


httpd.conf
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php

I failed similar to previous comments when trying to install it the same way on FreeBSD 4.4

./apachectl start
Syntax error on line 230 of 
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into 
server: /usr/local/apache2/modules/libphp4.so: Undefined 
symbol "pthread_getspecific"
./apachectl start: httpd could not be started
 [2002-05-28 16:02 UTC] info at wired dot com
Please Fix this !
Buggy PHP !
 [2002-06-13 09:48 UTC] sniper@php.net
See bug: http://bugs.php.net/?id=14594 which has good explanation what the problem is and how to solve it.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 17 09:03:34 2021 UTC