php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17286 PHP4.2.1 fails to compile on Solaris 8 (02/02)
Submitted: 2002-05-17 05:42 UTC Modified: 2002-05-20 21:14 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: michel dot jansens at ulb dot ac dot be Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 4.2.1 OS: Solaris 8 (02/02)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michel dot jansens at ulb dot ac dot be
New email:
PHP Version: OS:

 

 [2002-05-17 05:42 UTC] michel dot jansens at ulb dot ac dot be
./configure --with-apxs=/usr/products/apache/bin/apxs
make

Making all in Zend
/bin/sh ../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../main    -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=280 -DMOD_SSL=208108 -DEAPI -DEAPI_MM -DUSE_EXPAT -I../TSRM  -g -O2 -prefer-pic -c -o zend_language_parser.lo `test -f zend_language_parser.c || echo './'`zend_language_parser.c
In file included from zend_compile.h:24,
                 from zend_language_parser.c:147:
zend.h:55: unix.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `zend_language_parser.lo'
Current working directory /usr/products/src/php-4.2.1/Zend
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-20 15:57 UTC] matt at mail4friends dot com
The code in the configure script changed between 4.2.0 and 4.2.1, probably meaning a newer autoconf version was used.  This newer code falsely detects the unix.h header as being present on the system.  See starting line 6697 in 4.2.1 configure vs line 8580 in 4.2.0 configure for code differences.
 [2002-05-20 21:14 UTC] edink@php.net
Due to the bug in autoconf on Solaris you need to configure php with:

CC=gcc ./configure...
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 02 21:04:48 2022 UTC