php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17191 PHP Variables undefined
Submitted: 2002-05-13 17:36 UTC Modified: 2002-05-14 02:19 UTC
From: jens dot kammann at gmx dot de Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.2.1 OS: Win 2000 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jens dot kammann at gmx dot de
New email:
PHP Version: OS:

 

 [2002-05-13 17:36 UTC] jens dot kammann at gmx dot de
Because of the known "OCX-Control missing" problem I did a manual configuration on Windows 2000 Server (IIS5). PHP scripts run (e.g. phpinfo()), but own function don't have access to PHP Variables, there seem to be no variable definitions at all.
Calling a script via http://localhost/test.php?a=1 does not result in a variable "a" within the script.
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-13 17:45 UTC] manuzhai@php.net
That makes sense if you haven't turned the register_globals directive On in php.ini.
 [2002-05-13 18:05 UTC] jens dot kammann at gmx dot de
No, I've already changed both "register_globals" and "register_argc_argv" to "On".

Now, e.g. $OS is defined. However, Variables passed via URL still remaine undefined. 

(I am using the same PHP.INI File than on an XP-Installation, where PHP&IIS5 work. Are there any other modifications performed by the OCX which I am still missing ?)
 [2002-05-14 02:19 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 18:01:30 2024 UTC