php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17175 mail() can't work after I upgrade my php from 4.0.4pl1 to 4.2
Submitted: 2002-05-13 06:17 UTC Modified: 2002-05-13 06:32 UTC
From: Palvin at 163 dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.2.0 OS: RedHat 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Palvin at 163 dot com
New email:
PHP Version: OS:

 

 [2002-05-13 06:17 UTC] Palvin at 163 dot com
I upgrade my apache from 1.3 to 2.0.36 and php from 4.0.4pl1 to 4.2. Then I found that the mail() can't work and it's can work fine before I upgrade. The configure command of php4.2 is:
'./configure' '--prefix=/usr/local/php4.2' '--exec-prefix=/usr/local' '--bindir=/usr/local/bin' '--sbindir=/usr/local/sbin' '--libexecdir=/usr/local/libexec' '--datadir=/usr/local/share' '--sysconfdir=/usr/local/etc' '--sharedstatedir=/usr/local/com' '--localstatedir=/usr/local/var' '--libdir=/usr/local/lib' '--includedir=/usr/local/include' '--oldincludedir=/usr/include' '--infodir=/usr/local/info' '--mandir=/usr/local/man' '--enable-ftp' '--enable-gd-native-ttf' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-overload' '--enable-sockets' '--enable-aggregate' '--with-mod_charset' '--with-mysql' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-config-file-path=/etc' '--with-imap=/usr/lib' '--with-imap-ssl=/usr/lib' '--with-kerberos=/usr/kerberos' '--with-pear=/usr/local/php4.2/lib/php' '--with-exec-dir=/usr/local/bin' '--with-bz2=/usr/bin' '--with-java=/opt/jdk1.3.1' '--with-oci8=/u02/app/oracle/product/ora816' '--with-oracle=/u02/app/oracle/product/ora816' 

How to resolve it? I wish somebody can help me!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-13 06:20 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-05-13 06:32 UTC] mfischer@php.net
Btw, can you check your config.log if it found sendmail during ./configure? ./configure was quite buggy with the 4.2.0 release, maybe that's a another side effect we weren't aware yet.
 [2002-05-13 06:50 UTC] Palvin at 163 dot com
I've check the config.log and find about some sendmail infomation:
configure:7017: checking for sendmail
configure:7034: found /usr/sbin/sendmail
configure:7034: found /usr/sbin/sendmail
...
ac_cv_path_PROG_SENDMAIL=/usr/sbin/sendmail
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 14:05:53 2022 UTC