php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17147 undefined symbol: sapi_globals
Submitted: 2002-05-10 18:06 UTC Modified: 2002-06-06 21:00 UTC
From: admin at chartwayenterprises dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.0 OS: Slackware 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at chartwayenterprises dot com
New email:
PHP Version: OS:

 

 [2002-05-10 18:06 UTC] admin at chartwayenterprises dot com
On slackware 8.0 (Apache 2.0.36, upgraded from 1.3.20, where it worked fine), installed the module, it went fine, into src/modules.. made a .so, loaded it, and:
Syntax error on line 1023 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_php4.so into server: /usr/local/apache
/libexec/mod_php4.so: undefined symbol: sapi_globals
root@server:/usr/local/apache/src#

I've tried re-downloading, compiling and make'ing PHP..

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-06 21:00 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 04:03:37 2021 UTC